blob: 15ec51b2b850abd645ac4ec394d5c019b256bb8b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = " \
6 dbus \
7 dbus-glib \
8 dbus-glib-native \
9 libnotify \
10 libxfce4util \
11 libxfce4ui \
12 xfconf \
13 xfce4-panel \
14"
15
16inherit xfce-app
17
18SRC_URI[md5sum] = "ecb930ef6ae6e1f310a5afe5f638eff8"
19SRC_URI[sha256sum] = "f6f28af47fdfb41db84bd003f0d76f5f4abf2137d1e27e9d378f063bb8f82356"
20
21# Avoid trouble with other desktops e.g KDE which also ships dbus service named
22# org.freedesktop.Notifications
23EXTRA_OECONF = "--disable-dbus-start-daemon"
24
25do_compile_prepend() {
26 mkdir -p xfce4-notifyd xfce4-notifyd-config
27}
28
29FILES_${PN} += " \
30 ${systemd_user_unitdir} \
31 ${datadir}/xfce4 \
32 ${datadir}/themes \
33 ${datadir}/dbus-1 \
34 ${libdir}/xfce4 \
35"