blob: 884999c08e75606d01ea56628ab213a1fb4a70f2 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301# Copyright (C) 2017 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Lynis is a free and open source security and auditing tool."
5HOMEDIR = "https://cisofy.com/"
6LICENSE = "GPL-3.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1"
8
Stefan Lendl956c0482018-11-15 16:02:18 +01009SRCREV= "1be5154b35ce144db4f386856debe8a06b403899"
10SRC_URI = "git://github.com/CISOfy/Lynis.git"
11S = "${WORKDIR}/git"
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053012
13inherit autotools-brokensep
14
15do_compile[noexec] = "1"
16do_configure[noexec] = "1"
17
18do_install () {
19 install -d ${D}/${bindir}
20 install -d ${D}/${sysconfdir}/lynis
21 install -m 555 ${S}/lynis ${D}/${bindir}
22
23 install -d ${D}/${datadir}/lynis/db
24 install -d ${D}/${datadir}/lynis/plugins
25 install -d ${D}/${datadir}/lynis/include
26 install -d ${D}/${datadir}/lynis/extras
27
28 cp -r ${S}/db/* ${D}/${datadir}/lynis/db/.
29 cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/.
30 cp -r ${S}/include/* ${D}/${datadir}/lynis/include/.
31 cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/.
32 cp ${S}/*.prf ${D}/${sysconfdir}/lynis
33}
34
35FILES_${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf"
36FILES_${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md"
37
38RDEPENDS_${PN} += "procps"