blob: f670bffce550f5a0b73723d5a7d86f5de805cd88 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM."
2DESCRIPTION = " \
3 The tpm-tools package contains commands to allow the platform administrator \
4 the ability to manage and diagnose the platform's TPM. Additionally, the \
5 package contains commands to utilize some of the capabilities available \
6 in the TPM PKCS#11 interface implemented in the openCryptoki project. \
7 "
8SECTION = "tpm"
9LICENSE = "CPL-1.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9"
11
12DEPENDS = "libtspi openssl"
13DEPENDS_class-native = "trousers-native"
14
15SRCREV = "5c5126bedf2da97906358adcfb8c43c86e7dd0ee"
16SRC_URI = " \
17 git://git.code.sf.net/p/trousers/tpm-tools \
18 file://tpm-tools-extendpcr.patch \
19 "
20
21PV = "1.3.9.1+git${SRCPV}"
22
23inherit autotools-brokensep gettext
24
25S = "${WORKDIR}/git"
26
27do_configure_prepend () {
28 mkdir -p po
29 mkdir -p m4
30 cp -R po_/* po/
31 touch po/Makefile.in.in
32 touch m4/Makefile.am
33}
34
35BBCLASSEXTEND = "native"