blob: f7dce129643a3e9d40ef3da2a367f0521124cdd1 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "library with support for Expert Witness Compression Format"
2LICENSE = "LGPLv3+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=58c39b26c0549f8e1bb4122173f474cd"
4
5DEPENDS = "virtual/gettext libtool"
6
7SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/libe/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
8 file://gcc5_fix.patch \
9 "
10SRC_URI[orig.md5sum] = "fdf615f23937fad8e02b60b9e3e5fb35"
11SRC_URI[orig.sha256sum] = "d14030ce6122727935fbd676d0876808da1e112721f3cb108564a4d9bf73da71"
12
13inherit autotools-brokensep pkgconfig gettext
14
15PACKAGECONFIG ??= "zlib ssl bz2"
16PACKAGECONFIG[zlib] = "--with-zlib, --without-zlib, zlib, zlib"
17PACKAGECONFIG[bz2] = "--with-bzip2, --without-bzip2, bzip2, bzip2"
18PACKAGECONFIG[ssl] = "--with-openssl, --without-openssl, openssl, openssl"
19PACKAGECONFIG[fuse] = "--with-libfuse, --without-libfuse, fuse"
20PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
21
22EXTRA_OECONF += "--with-gnu-ld --disable-rpath"
23
24RDEPENDS_${PN} += " util-linux-libuuid"