blob: cff4a265bd4af0d7504ba3b8214ee2fa282879ba [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001
2require newlib.inc
3
4DEPENDS += "newlib"
5
6do_configure() {
7 ${S}/libgloss/configure ${EXTRA_OECONF}
8}
9
10do_install_prepend() {
11 # install doesn't create this itself, avoid install error
12 install -d ${D}${prefix}/${TARGET_SYS}/lib
13}
14
15do_install_append() {
16 # Move libs to default directories so they can be picked up later
17 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
18
19 # Remove original directory
20 rmdir ${D}${prefix}/${TARGET_SYS}
21}
22
23# Split packages correctly
24FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
25
26INHIBIT_PACKAGE_STRIP = "1"
27INHIBIT_PACKAGE_DEBUG_SPLIT = "1"