blob: 3d313503f819d1931d18df85714c07157957bb3a [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001require newlib.inc
2
3do_configure_prepend_microblaze() {
4 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC)
5 export CC="${CC} -L${S}/libgloss/microblaze"
6}
7
8do_configure() {
9 ${S}/configure ${EXTRA_OECONF}
10}
11
12do_install_append() {
13 # Move include files and libs to default directories so they can be picked up later
14 mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
15 mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
16
17 # Remove original directory
18 rmdir ${D}${prefix}/${TARGET_SYS}
19}