blob: c68a2ef367df4af1f9a397be58fa1f65ce96c23f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=5b8620d98e49772d95fc1d291c26aa79"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
10 file://autotools.patch \
11 file://libtool-tag.patch \
12 "
13
14SRC_URI[md5sum] = "789e297f547980fc9ecc036f9a070d49"
15SRC_URI[sha256sum] = "d9dc32efba7e74f788fcc4f212a43216fc37cf5f23f4c2339664d473353aedf6"
16
17inherit autotools lib_package
18
19do_configure_prepend () {
20 rm -f ${S}/conftools/libtool.m4
21}
22
23BBCLASSEXTEND = "native nativesdk"