blob: 66046480b90f9a562f52c479e3b19da7f3ccf42f [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "A parallel build system"
2DESCRIPTION = "distcc is a parallel build system that distributes \
3compilation of C/C++/ObjC code across machines on a network."
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "avahi binutils"
9
10PACKAGECONFIG ??= "popt"
11PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
12# use system popt by default
13PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
14
15RRECOMMENDS_${PN} = "avahi-daemon"
16
Brad Bishop00111322018-04-01 22:23:53 -040017SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 file://separatebuilddir.patch \
19 file://0001-zeroconf-Include-fcntl.h.patch \
20 file://default \
21 file://distccmon-gnome.desktop \
22 file://distcc \
23 file://distcc.service"
24SRCREV = "d8b18df3e9dcbe4f092bed565835d3975e99432c"
25S = "${WORKDIR}/git"
26
27inherit autotools pkgconfig update-rc.d useradd systemd
28
29EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
30
31USERADD_PACKAGES = "${PN}"
32USERADD_PARAM_${PN} = "--system \
33 --home /dev/null \
34 --no-create-home \
35 --gid nogroup \
36 distcc"
37
38INITSCRIPT_NAME = "distcc"
39
40SYSTEMD_PACKAGES = "${PN}"
41SYSTEMD_SERVICE_${PN} = "distcc.service"
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043do_install() {
44 # Improve reproducibility: compress w/o timestamps
45 oe_runmake 'DESTDIR=${D}' "GZIP_BIN=gzip -n" install
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046 install -d ${D}${sysconfdir}/init.d/
47 install -d ${D}${sysconfdir}/default
48 install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
49 install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
50 install -d ${D}${systemd_unitdir}/system/
51 install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
52 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
53 ${DESKTOPINSTALL}
54}
55DESKTOPINSTALL = ""
56DESKTOPINSTALL_libc-glibc () {
57 install -d ${D}${datadir}/distcc/
58 install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
59}
60PACKAGES += "distcc-distmon-gnome"
61
62FILES_${PN} = " ${sysconfdir} \
63 ${bindir}/distcc \
64 ${bindir}/lsdistcc \
65 ${bindir}/distccd \
66 ${bindir}/distccmon-text \
67 ${systemd_unitdir}/system/distcc.service"
68FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
69 ${datadir}/distcc"