blob: 790930cf359595593ed72ca1a1bfc4cc66563c29 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001From: Kurt Roeckx <kurt@roeckx.be>
2Subject: Make readelf -w output debug information on mips
3Bug-Debian: http://bugs.debian.org/662041
4Forwarded: not-needed
5
6Upstreams wants a change where this is handled by a hook that needs
7to be filled in by the backend for the arch.
8
9Upstream-Status: Backport [from debian]
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11
12Index: b/src/readelf.c
13===================================================================
14--- a/src/readelf.c
15+++ b/src/readelf.c
16@@ -8343,7 +8343,8 @@ print_debug (Dwfl_Module *dwflmod, Ebl *
17 GElf_Shdr shdr_mem;
18 GElf_Shdr *shdr = gelf_getshdr (scn, &shdr_mem);
19
20- if (shdr != NULL && shdr->sh_type == SHT_PROGBITS)
21+ if (shdr != NULL && (
22+ (shdr->sh_type == SHT_PROGBITS) || (shdr->sh_type == SHT_MIPS_DWARF)))
23 {
24 static const struct
25 {