blob: ea8fef122c09a84e0bd89b43aef18496e7721d4c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require gdb.inc
2require gdb-${PV}.inc
3
4inherit python3-dir
5
6EXTRA_OEMAKE_append_libc-musl = "\
7 gt_cv_func_gnugettext1_libc=yes \
8 gt_cv_func_gnugettext2_libc=yes \
9 gl_cv_func_gettimeofday_clobber=no \
10 "
11
12do_configure_prepend() {
13 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
14 cat > ${WORKDIR}/python << EOF
15#!/bin/sh
16case "\$2" in
17 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
18 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
19 --exec-prefix) echo "${exec_prefix}" ;;
20 *) exit 1 ;;
21esac
22exit 0
23EOF
24 chmod +x ${WORKDIR}/python
25 fi
26}
27CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"