blob: ec5a314e7d68501c963b6d1bae199be628492057 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require go-${PV}.inc
2require go-target.inc
Brad Bishop316dfdd2018-06-25 12:45:53 -04003
4export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}"
8
9do_compile() {
10 export GOBIN="${B}/bin"
11 export TMPDIR="$GOTMPDIR"
12 export CC=$BUILD_CC
13
14 cd src
15 ./make.bash
16 cd ${B}
17}