blob: 06319de3239ebedd73dac69ecd566e017a9f69e8 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 "
9SRC_URI[md5sum] = "11fc5d90c77375e5fc8401e8b9efbf21"
10SRC_URI[sha256sum] = "0316780be9ad16c42d7c26b015a784fd5df4b0909fef0aba51cfb13e492ac24d"
11
12UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
13# json-c releases page is fetching the list of releases in some weird XML format
14# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
15#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
16RECIPE_UPSTREAM_VERSION = "0.13"
17RECIPE_UPSTREAM_DATE = "Dec 07, 2017"
18CHECK_DATE = "Jan 31, 2018"
19
20RPROVIDES_${PN} = "libjson"
21
22inherit autotools
23
24EXTRA_OECONF = "--enable-rdrand"
25
26do_configure_prepend() {
27 # Clean up autoconf cruft that should not be in the tarball
28 rm -f ${S}/config.status
29}
30
31BBCLASSEXTEND = "native nativesdk"