blob: 49238f3df53d4d1d6b7078b8377b811573626704 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "37d44a08e599aa945b32a9434ffe00a5"
17SRC_URI[sha256sum] = "cca7ab4a6f63f3ccaacae0f2e1337e8edf84137e73f18548ec7d659f23efe413"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan ptest-perl
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30do_install_prepend() {
31 # these tests require "-T" (taint) command line option
32 rm -rf ${B}/t/cwd.t
33 rm -rf ${B}/t/file.t
34}
35
36RDEPENDS_${PN}-ptest += "libtest-needs-perl"
37
38BBCLASSEXTEND = "native"