blob: a447dc719605b03092c2ddfd7253cb365a0461e6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI = "http://wiki.qemu-project.org/download/${BP}.tar.bz2 \
11 file://powerpc_rom.bin \
Brad Bishopd5ae7d92018-06-14 09:52:03 -070012 file://0001-sdl.c-allow-user-to-disable-pointer-grabs.patch \
13 file://0002-qemu-Add-missing-wacom-HID-descriptor.patch \
14 file://0003-Add-subpackage-ptest-which-runs-all-unit-test-cases-.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015 file://run-ptest \
Brad Bishopd5ae7d92018-06-14 09:52:03 -070016 file://0004-qemu-Add-addition-environment-space-to-boot-loader-q.patch \
17 file://0005-qemu-disable-Valgrind.patch \
18 file://0006-qemu-Limit-paths-searched-during-user-mode-emulation.patch \
19 file://0007-qemu-native-set-ld.bfd-fix-cflags-and-set-some-envir.patch \
20 file://0008-chardev-connect-socket-to-a-spawned-command.patch \
21 file://0009-apic-fixup-fallthrough-to-PIC.patch \
22 file://0010-linux-user-Fix-webkitgtk-hangs-on-32-bit-x86-target.patch \
23 file://0011-memfd-fix-configure-test.patch \
24 file://0012-arm-translate-a64-treat-DISAS_UPDATE-as-variant-of-D.patch \
25 file://0013-ps2-check-PS2Queue-pointers-in-post_load-routine.patch \
26 file://0001-CVE-2018-11806-QEMU-slirp-heap-buffer-overflow.patch \
Brad Bishop220d5532018-08-14 00:59:39 +010027 file://CVE-2018-7550.patch \
28 file://CVE-2018-12617.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040029 "
30UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+\..*)\.tar"
31
Brad Bishop316dfdd2018-06-25 12:45:53 -040032SRC_URI_append_class-native = " \
Brad Bishopd5ae7d92018-06-14 09:52:03 -070033 file://0014-fix-libcap-header-issue-on-some-distro.patch \
34 file://0015-cpus.c-Add-error-messages-when-qemi_cpu_kick_thread-.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040035 "
36
37SRC_URI[md5sum] = "61cf862b6007eba4ac98247776af2e27"
38SRC_URI[sha256sum] = "d9df2213ceed32e91dab7bc9dd19c1af83f91ba72c7aeef7605dfaaf81732ccb"
39
40COMPATIBLE_HOST_mipsarchn32 = "null"
41COMPATIBLE_HOST_mipsarchn64 = "null"
42
43do_install_append() {
44 # Prevent QA warnings about installed ${localstatedir}/run
45 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
46 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
47}
48
49do_compile_ptest() {
50 make buildtest-TESTS
51}
52
53do_install_ptest() {
54 cp -rL ${B}/tests ${D}${PTEST_PATH}
55 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
56
57 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
58 # Don't check the file genreated by configure
59 sed -i -e '/wildcard config-host.mak/d' \
60 -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
61}