blob: 39ec6f5cc837aa80cfd7a2cb1e7dc04250ad38ba [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "ftp://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
30 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
31 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
32 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
33 file://0001-memcheck-tests-Use-ucontext_t-instead-of-struct-ucon.patch \
34 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
35 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
36 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
37 file://link-gz-tests.patch \
38 file://ppc-headers.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 file://mask-CPUID-support-in-HWCAP-on-aarch64.patch \
Brad Bishop6f8dcde2018-10-16 10:47:12 +080040 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
41 file://0002-fix-broken-inline-asm-in-tests-on-mips32-linux.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042 "
43SRC_URI[md5sum] = "817dd08f1e8a66336b9ff206400a5369"
44SRC_URI[sha256sum] = "d76680ef03f00cd5e970bbdcd4e57fb1f6df7d2e2c071635ef2be74790190c3b"
45UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
46
47COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
48
49# valgrind supports armv7 and above
50COMPATIBLE_HOST_armv4 = 'null'
51COMPATIBLE_HOST_armv5 = 'null'
52COMPATIBLE_HOST_armv6 = 'null'
53
54# X32 isn't supported by valgrind at this time
55COMPATIBLE_HOST_linux-gnux32 = 'null'
56COMPATIBLE_HOST_linux-muslx32 = 'null'
57
58# Disable for some MIPS variants
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059COMPATIBLE_HOST_mipsarchr6 = 'null'
60
Brad Bishop00111322018-04-01 22:23:53 -040061inherit autotools ptest multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050062
63EXTRA_OECONF = "--enable-tls --without-mpicc"
64EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
65
66# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
67EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
68TARGET_CC_ARCH_remove_arm = "${@get_mcpu(d)}"
69
70EXTRA_OEMAKE = "-w"
71
72CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
73
74# valgrind likes to control its own optimisation flags. It generally defaults
75# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
76# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
77# which fixes build path issue in DWARF.
78SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
79
80def get_mcpu(d):
81 for arg in (d.getVar('TUNE_CCARGS') or '').split():
82 if arg.startswith('-mcpu='):
83 return arg
84 else:
85 continue
86 return ""
87
88do_configure_prepend () {
89 rm -rf ${S}/config.h
Brad Bishop316dfdd2018-06-25 12:45:53 -040090 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
91 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
Brad Bishopd7bf8c12018-02-25 22:55:05 -050092}
93
94do_install_append () {
95 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
Brad Bishop00111322018-04-01 22:23:53 -040096 oe_multilib_header valgrind/config.h
Brad Bishopd7bf8c12018-02-25 22:55:05 -050097}
98
99TUNE = "${@strip_mcpu(d)}"
100
101RDEPENDS_${PN} += "perl"
102
103# valgrind needs debug information for ld.so at runtime in order to
104# redirect functions like strlen.
105RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
106
107RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
108RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
109
110# One of the tests contains a bogus interpreter path on purpose.
111# Skip file dependency check
112SKIP_FILEDEPS_${PN}-ptest = '1'
113
114do_compile_ptest() {
115 oe_runmake check
116}
117
118do_install_ptest() {
119 chmod +x ${B}/tests/vg_regtest
120
121 # The test application binaries are not automatically installed.
122 # Grab them from the build directory.
123 #
124 # The regression tests require scripts and data files that are not
125 # copied to the build directory. They must be copied from the
126 # source directory.
127 saved_dir=$PWD
128 for parent_dir in ${S} ${B} ; do
129 cd $parent_dir
130
131 # exclude shell or the package won't install
132 rm -rf none/tests/shell* 2>/dev/null
133
134 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
135
136 # Get the vg test scripts, filters, and expected files
137 for dir in $subdirs ; do
138 find $dir | cpio -pvdu ${D}${PTEST_PATH}
139 done
140 cd $saved_dir
141 done
142
143 # clean out build artifacts before building the rpm
144 find ${D}${PTEST_PATH} \
145 \( -name "Makefile*" \
146 -o -name "*.o" \
147 -o -name "*.c" \
148 -o -name "*.S" \
149 -o -name "*.h" \) \
150 -exec rm {} \;
151
152 # needed by massif tests
153 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
154
155 # handle multilib
156 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
157}