blob: 990cf9178bb6b1657b8227d935c96261c7e76023 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Rotates, compresses, removes and mails system log files"
2SECTION = "console/utils"
3HOMEPAGE = "https://github.com/logrotate/logrotate/issues"
4LICENSE = "GPLv2"
5
6# TODO: Document coreutils dependency. Why not RDEPENDS? Why not busybox?
7
8DEPENDS="coreutils popt"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12# When updating logrotate to latest upstream, SRC_URI should point to
13# a proper release tarball from https://github.com/logrotate/logrotate/releases
14# and we have to take the snapshot for now because there is no such
15# tarball available for 3.9.1.
16
17S = "${WORKDIR}/${BPN}-${PV}"
18
19UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
20UPSTREAM_CHECK_REGEX = "logrotate-(?P<pver>\d+(\.\d+)+).tar"
21
22SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \
23 file://act-as-mv-when-rotate.patch \
24 file://update-the-manual.patch \
25 file://disable-check-different-filesystems.patch \
26 "
27
28SRC_URI[md5sum] = "78ef24d6fddcc4df8e412dd75c551b4c"
29SRC_URI[sha256sum] = "3222ca032f99be8d7a4a8c6ad69f3dcc49b9511bfe384bd5a271ebcd9bd3e52c"
30
31PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)}"
32
33PACKAGECONFIG[acl] = ",,acl"
34PACKAGECONFIG[selinux] = ",,libselinux"
35
36CONFFILES_${PN} += "${localstatedir}/lib/logrotate.status \
37 ${sysconfdir}/logrotate.conf"
38
39# If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
40# optimization variables, so use it rather than EXTRA_CFLAGS.
41EXTRA_OEMAKE = "\
42 LFS= \
43 OS_NAME='${OS_NAME}' \
44 'CC=${CC}' \
45 'RPM_OPT_FLAGS=${CFLAGS}' \
46 'EXTRA_LDFLAGS=${LDFLAGS}' \
47 ${@bb.utils.contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
48 ${@bb.utils.contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
49"
50
51# OS_NAME in the makefile defaults to `uname -s`. The behavior for
52# freebsd/netbsd is questionable, so leave it as Linux, which only sets
53# INSTALL=install and BASEDIR=/usr.
54OS_NAME = "Linux"
55
56inherit autotools systemd
57
58SYSTEMD_SERVICE_${PN} = "\
59 ${BPN}.service \
60 ${BPN}.timer \
61"
62
63LOGROTATE_SYSTEMD_TIMER_BASIS ?= "daily"
64LOGROTATE_SYSTEMD_TIMER_ACCURACY ?= "12h"
65
66do_install(){
67 oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
68 mkdir -p ${D}${sysconfdir}/logrotate.d
69 mkdir -p ${D}${localstatedir}/lib
70 install -p -m 644 ${S}/examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
71 touch ${D}${localstatedir}/lib/logrotate.status
72
73 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
74 install -d ${D}${systemd_system_unitdir}
75 install -m 0644 ${S}/examples/logrotate.service ${D}${systemd_system_unitdir}/logrotate.service
76 install -m 0644 ${S}/examples/logrotate.timer ${D}${systemd_system_unitdir}/logrotate.timer
77 sed -i -e 's,OnCalendar=.*$,OnCalendar=${LOGROTATE_SYSTEMD_TIMER_BASIS},g' ${D}${systemd_system_unitdir}/logrotate.timer
78 sed -i -e 's,AccuracySec=.*$,AccuracySec=${LOGROTATE_SYSTEMD_TIMER_ACCURACY},g' ${D}${systemd_system_unitdir}/logrotate.timer
79 fi
80
81 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
82 mkdir -p ${D}${sysconfdir}/cron.daily
83 install -p -m 0755 ${S}/examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
84 fi
85}