blob: 9002fbc3732ea6ff493cada52487db0a3b687db2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Standard full-featured Linux system"
6DESCRIPTION = "Package group bringing in packages needed for a more traditional full-featured Linux system"
7PR = "r6"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9inherit packagegroup
10
11PACKAGES = "\
12 packagegroup-core-full-cmdline \
13 packagegroup-core-full-cmdline-libs \
14 packagegroup-core-full-cmdline-utils \
15 packagegroup-core-full-cmdline-extended \
16 packagegroup-core-full-cmdline-dev-utils \
17 packagegroup-core-full-cmdline-multiuser \
18 packagegroup-core-full-cmdline-initscripts \
19 packagegroup-core-full-cmdline-sys-services \
20 "
21
22python __anonymous () {
23 # For backwards compatibility after rename
24 namemap = {}
25 namemap["packagegroup-core-full-cmdline"] = "packagegroup-core-basic"
26 namemap["packagegroup-core-full-cmdline-libs"] = "packagegroup-core-basic-libs"
27 namemap["packagegroup-core-full-cmdline-utils"] = "packagegroup-core-basic-utils"
28 namemap["packagegroup-core-full-cmdline-extended"] = "packagegroup-core-basic-extended"
29 namemap["packagegroup-core-full-cmdline-dev-utils"] = "packagegroup-core-dev-utils"
30 namemap["packagegroup-core-full-cmdline-multiuser"] = "packagegroup-core-multiuser"
31 namemap["packagegroup-core-full-cmdline-initscripts"] = "packagegroup-core-initscripts"
32 namemap["packagegroup-core-full-cmdline-sys-services"] = "packagegroup-core-sys-services"
33
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034 packages = d.getVar("PACKAGES").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 for pkg in packages:
36 if pkg.endswith('-dev'):
37 mapped = namemap.get(pkg[:-4], None)
38 if mapped:
39 mapped += '-dev'
40 elif pkg.endswith('-dbg'):
41 mapped = namemap.get(pkg[:-4], None)
42 if mapped:
43 mapped += '-dbg'
44 else:
45 mapped = namemap.get(pkg, None)
46
47 if mapped:
48 oldtaskname = mapped.replace("packagegroup-core", "task-core")
49 mapstr = " %s %s" % (mapped, oldtaskname)
50 d.appendVar("RPROVIDES_%s" % pkg, mapstr)
51 d.appendVar("RREPLACES_%s" % pkg, mapstr)
52 d.appendVar("RCONFLICTS_%s" % pkg, mapstr)
53}
54
55
56RDEPENDS_packagegroup-core-full-cmdline = "\
57 packagegroup-core-full-cmdline-libs \
58 packagegroup-core-full-cmdline-utils \
59 packagegroup-core-full-cmdline-extended \
60 packagegroup-core-full-cmdline-dev-utils \
61 packagegroup-core-full-cmdline-multiuser \
62 packagegroup-core-full-cmdline-initscripts \
63 packagegroup-core-full-cmdline-sys-services \
64 "
65
66RDEPENDS_packagegroup-core-full-cmdline-libs = "\
67 glib-2.0 \
68 "
69
70RDEPENDS_packagegroup-core-full-cmdline-utils = "\
71 bash \
72 acl \
73 attr \
74 bc \
75 coreutils \
76 cpio \
77 e2fsprogs \
78 ed \
79 file \
80 findutils \
81 gawk \
82 gmp \
83 grep \
84 makedevs \
85 mc \
86 mc-fish \
87 mc-helpers \
88 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089 mktemp \
90 ncurses \
91 net-tools \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092 popt \
93 procps \
94 psmisc \
95 sed \
96 tar \
97 time \
98 util-linux \
99 zlib \
100 "
101
102RDEPENDS_packagegroup-core-full-cmdline-extended = "\
103 iproute2 \
104 iputils \
105 iptables \
106 module-init-tools \
107 openssl \
108 "
109
110RDEPENDS_packagegroup-core-full-cmdline-dev-utils = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500111 diffutils \
112 m4 \
113 make \
114 patch \
115 "
116
117VIRTUAL-RUNTIME_initscripts ?= "initscripts"
118VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
119VIRTUAL-RUNTIME_login_manager ?= "busybox"
120VIRTUAL-RUNTIME_syslog ?= "sysklogd"
121RDEPENDS_packagegroup-core-full-cmdline-initscripts = "\
122 ${VIRTUAL-RUNTIME_initscripts} \
123 ${VIRTUAL-RUNTIME_init_manager} \
124 ethtool \
125 ${VIRTUAL-RUNTIME_login_manager} \
126 ${VIRTUAL-RUNTIME_syslog} \
127 "
128
129RDEPENDS_packagegroup-core-full-cmdline-multiuser = "\
130 cracklib \
131 gzip \
132 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libuser', '', d)} \
133 shadow \
134 sudo \
135 "
136
137RDEPENDS_packagegroup-core-full-cmdline-sys-services = "\
138 at \
139 bzip2 \
140 cronie \
141 dbus \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500142 elfutils \
143 gzip \
144 less \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145 logrotate \
146 nfs-utils \
147 pciutils \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500148 rpcbind \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500149 tcp-wrappers \
150 tzdata \
151 "