blob: cdcbebffce61eafacced367952cd7f0aaaf1e904 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003DESCRIPTION = "XML::SAX consists of several framework classes for using and \
4building Perl SAX2 XML parsers, filters, and drivers. It is designed \
5around the need to be able to "plug in" different SAX parsers to an \
6application without requiring programmer intervention. Those of you \
7familiar with the DBI will be right at home. Some of the designs \
8come from the Java JAXP specification (SAX part), only without the \
9javaness."
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13DEPENDS += "libxml-namespacesupport-perl-native"
14RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
15PR = "r2"
16
17LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
18
19SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
20
21SRC_URI[md5sum] = "290f5375ae87fdebfdb5bc3854019f24"
22SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6f5ad84"
23
24S = "${WORKDIR}/XML-SAX-${PV}"
25
Brad Bishop316dfdd2018-06-25 12:45:53 -040026inherit cpan ptest-perl
27
28do_install_ptest() {
29 cp -r ${B}/testfiles ${D}${PTEST_PATH}
30 chown -R root:root ${D}${PTEST_PATH}/testfiles
31}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032
33BBCLASSEXTEND = "native"