blob: 7339289de6ce112cde76610008d973b26cb9d645 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Basic desktop integration functions"
2HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xdg-utils/"
3DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \
4desktop integration functions for any Free Desktop, such as Linux. \
5They are intended to provide a set of defacto standards. \
6The following scripts are provided at this time: \
7xdg-desktop-icon \
8xdg-desktop-menu \
9xdg-email \
10xdg-icon-resource \
11xdg-mime \
12xdg-open \
13xdg-screensaver \
14xdg-terminal \
15"
16
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014"
19
20SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \
21 file://0001-Reinstate-xdg-terminal.patch \
22 file://0001-Don-t-build-the-in-script-manual.patch \
23 "
24
25SRC_URI[md5sum] = "361e75eb76c94d19f6f4f330d8ee626b"
26SRC_URI[sha256sum] = "951952e2c6bb21214e0bb54e0dffa057d30f5563300225c24c16fba846258bcc"
27
28UPSTREAM_CHECK_REGEX = "xdg-utils-(?P<pver>((\d+[\.\-_]*)+)((rc|alpha|beta)\d+)?)\.(tar\.gz|tgz)"
29
30# Needs brokensep as this doesn't use automake
31inherit autotools-brokensep distro_features_check
32
33# The xprop requires x11 in DISTRO_FEATURES
34REQUIRED_DISTRO_FEATURES = "x11"
35
36DEPENDS = "xmlto-native libxslt-native"
37RDEPENDS_${PN} += "xprop"