blob: c0f8b82f6415b7c78bd19892c1328ff0e0ba7746 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Utilities for managing LZMA compressed files"
2HOMEPAGE = "http://tukaani.org/xz/"
3SECTION = "base"
4
5# The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file
6# which is GPLv3 is an m4 macro which isn't shipped in any of our packages,
7# and the LGPL bits are under lib/, which appears to be used for libgnu, which
8# appears to be used for DOS builds. So we're left with GPLv2+ and PD.
9LICENSE = "GPLv2+ & GPL-3.0-with-autoconf-exception & LGPLv2.1+ & PD"
10LICENSE_${PN} = "GPLv2+"
11LICENSE_${PN}-dev = "GPLv2+"
12LICENSE_${PN}-staticdev = "GPLv2+"
13LICENSE_${PN}-doc = "GPLv2+"
14LICENSE_${PN}-dbg = "GPLv2+"
15LICENSE_${PN}-locale = "GPLv2+"
16LICENSE_liblzma = "PD"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=c475b6c7dca236740ace4bba553e8e1c \
19 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
20 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \
22 file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 "
23
24SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.gz"
25SRC_URI[md5sum] = "ef68674fb47a8b8e741b34e429d86e9d"
26SRC_URI[sha256sum] = "71928b357d0a09a12a4b4c5fafca8c31c19b0e7d3b8ebb19622e96f26dbf28cb"
27
28inherit autotools gettext
29
30PACKAGES =+ "liblzma"
31
32FILES_liblzma = "${libdir}/liblzma*${SOLIBS}"
33
34BBCLASSEXTEND = "native nativesdk"
35
36export CONFIG_SHELL="/bin/sh"