blob: d4cbce80b451f40fbfda710544af1d950e40ab4b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1367;endline=1382;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib gperf-native"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 file://0001-src-fcxml.c-avoid-double-free-of-filename.patch \
26 "
27
28SRC_URI[md5sum] = "00e748c67fad11e7057a71ed385e8bdb"
29SRC_URI[sha256sum] = "064b9ebf060c9e77011733ac9dc0e2ce92870b574cca2405e11f5353a683c334"
30
31UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
32
33do_configure_prepend() {
34 # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280
35 rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf
36}
37
38PACKAGES =+ "fontconfig-utils"
39FILES_${PN} =+ "${datadir}/xml/*"
40FILES_fontconfig-utils = "${bindir}/*"
41
42# Work around past breakage in debian.bbclass
43RPROVIDES_fontconfig-utils = "libfontconfig-utils"
44RREPLACES_fontconfig-utils = "libfontconfig-utils"
45RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
46DEBIAN_NOAUTONAME_fontconfig-utils = "1"
47
48inherit autotools pkgconfig relative_symlinks
49
50FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
51
52# comma separated list of additional directories
53# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
54FONTCONFIG_FONT_DIRS ?= "no"
55
56EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
57
58BBCLASSEXTEND = "native"