blob: 3bd9c647161bf4c0446e2383f17d1e6224030757 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
15
16SRC_URI += "file://run-ptest \
17 file://0001-Drop-introspection-macros-from-acinclude.m4.patch \
18 file://0001-Enforce-recreation-of-docs-pango.types-it-is-build-c.patch \
19"
20SRC_URI[archive.md5sum] = "18d7eb8d52e7e445e733c109ddaa7b78"
21SRC_URI[archive.sha256sum] = "90af1beaa7bf9e4c52db29ec251ec4fd0a8f2cc185d521ad1f88d01b3a6a17e3"
22
23DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
26PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft"
27
28EXTRA_OECONF = " \
29 --disable-debug \
30 "
31
32LEAD_SONAME = "libpango-1.0*"
33LIBV = "1.8.0"
34
35# This binary needs to be compiled for the host architecture. This isn't pretty!
36do_compile_prepend_class-target () {
37 if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
38 make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
39 fi
40}
41
42FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
43FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
44
45RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
46
47RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
48 pango-module-basic-fc pango-module-arabic-lang"
49
50BBCLASSEXTEND = "native"