blob: bef3636092127acba727a92b96c4f9565a76d597 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
4
5SUMMARY = "X.Org X server -- TI OMAP integrated graphics chipsets driver"
6
7DESCRIPTION = "Open-source X.org graphics driver for TI OMAP graphics \
8Currently relies on a closed-source submodule for EXA acceleration on \
9the following chipsets: \
10 + OMAP3430 \
11 + OMAP3630 \
12 + OMAP4430 \
13 + OMAP4460 \
14 + OMAP5430 \
15 + OMAP5432 \
16\
17NOTE: this driver is work in progress.. you probably don't want to try \
18and use it yet. The API/ABI between driver and kernel, and driver and \
19acceleration submodules is not stable yet. This driver requires the \
20omapdrm kernel driver w/ GEM support. \
21"
22
23LICENSE = "GPLv2+"
24LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602"
25DEPENDS += "virtual/libx11 libdrm xf86driproto"
26
27SRC_URI[md5sum] = "3b8ea5e8fba63355c0dc6681c49d5fe5"
28SRC_URI[sha256sum] = "93e7d42107521e61f61980eaea64fb452e87b7b94272e48938ac8d904ccfab5a"
29
30CFLAGS += " -I${STAGING_INCDIR}/xorg "
31
32# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
33do_compile_prepend_armv7a () {
34 sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
35}
36
37python () {
38 if not bb.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d):
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 raise bb.parse.SkipRecipe("'opengl' not in DISTRO_FEATURES")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040}
41