blob: cb4ef3a659c1ebabc17e26097b791884533e67fd [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001KBRANCH ?= "standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
Brad Bishopbba38f32018-08-23 16:11:46 +08007LINUX_VERSION ?= "4.12.28"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
Brad Bishopbba38f32018-08-23 16:11:46 +080012SRCREV_machine ?= "e562267bae5b518acca880c929fbbdf6be047e0a"
13SRCREV_meta ?= "2ae65226f64ed5c888d60eef76b6249db678d060"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "qemux86|qemux86-64"
21
22# Functionality flags
23KERNEL_FEATURES = ""
24
25KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"