blob: 92c86a3ef59adefe559d456bf3b2ea4d95f975e5 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://bjam-native-build-bjam.debug.patch \
9 file://0001-Fix-a-strange-assert-typo-how-was-this-released-with.patch"
10
11do_compile() {
12 ./bootstrap.sh --with-toolset=gcc
13}
14
15do_install() {
16 install -d ${D}${bindir}/
17 # install unstripped version for bjam
18 install -c -m 755 bjam.debug ${D}${bindir}/bjam
19}