blob: 5a3688acfb7b98d9ac18fcb5201e63f64c649e53 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
Brad Bishop220d5532018-08-14 00:59:39 +010017 file://CVE-2018-12020.patch \
Brad Bishop6ef32652018-10-09 18:59:25 +010018 file://CVE-2018-9234.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 "
Brad Bishopc4ea0752018-11-15 14:30:15 -080020SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
21 file://relocate.patch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23
24SRC_URI[md5sum] = "709e5af5bba84d251c520222e720972f"
25SRC_URI[sha256sum] = "401a3e64780fdfa6d7670de0880aa5c9d589b3db7a7098979d7606cec546f2ec"
26
27EXTRA_OECONF = "--disable-ldap \
28 --disable-ccid-driver \
29 --with-zlib=${STAGING_LIBDIR}/.. \
30 --with-bzip2=${STAGING_LIBDIR}/.. \
31 --with-readline=${STAGING_LIBDIR}/.. \
32 --enable-gpg-is-gpg2 \
33 "
34RRECOMMENDS_${PN} = "pinentry"
35
36do_configure_prepend () {
37 # Else these could be used in prefernce to those in aclocal-copy
38 rm -f ${S}/m4/gpg-error.m4
39 rm -f ${S}/m4/libassuan.m4
40 rm -f ${S}/m4/ksba.m4
41 rm -f ${S}/m4/libgcrypt.m4
42}
43
44do_install_append() {
45 ln -sf gpg2 ${D}${bindir}/gpg
46 ln -sf gpgv2 ${D}${bindir}/gpgv
47}
48
Brad Bishopc4ea0752018-11-15 14:30:15 -080049do_install_append_class-native() {
50 create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
51}
52
Brad Bishop316dfdd2018-06-25 12:45:53 -040053PACKAGECONFIG ??= "gnutls"
54PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
55PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
56
57BBCLASSEXTEND = "native"