blob: 9d036c8fb1cd72eef9d735ed6b049732b51d6074 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
14
15DEPENDS = "libgpg-error"
16
17UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
18SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
19 file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \
20 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
21 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
22 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
Brad Bishop220d5532018-08-14 00:59:39 +010023 file://CVE-2018-0495.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040024"
25SRC_URI[md5sum] = "cfb0b5c79eab07686b6898160a407139"
26SRC_URI[sha256sum] = "c8064cae7558144b13ef0eb87093412380efa16c4ee30ad12ecb54886a524c07"
27
28BINCONFIG = "${bindir}/libgcrypt-config"
29
30inherit autotools texinfo binconfig-disabled pkgconfig
31
32EXTRA_OECONF = "--disable-asm"
33EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
34
35PACKAGECONFIG ??= "capabilities"
36PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
37
38do_configure_prepend () {
39 # Else this could be used in preference to the one in aclocal-copy
40 rm -f ${S}/m4/gpg-error.m4
41}
42
43# libgcrypt.pc is added locally and thus installed here
44do_install_append() {
45 install -d ${D}/${libdir}/pkgconfig
46 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
47}
48
49PACKAGES =+ "dumpsexp-dev"
50
51FILES_${PN}-dev += "${bindir}/hmac256"
52FILES_dumpsexp-dev += "${bindir}/dumpsexp"
53
54BBCLASSEXTEND = "native nativesdk"