blob: b74f079f5d6ccd7c5e91bd154fbfb635f2b02449 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=23;md5=beae1e44d8d5c265d194760276033a7c \
9 file://src/init.c;endline=20;md5=872b2389fe9bae7ffb80d2b91225afbc"
10
11
12SECTION = "libs"
13
14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
16 file://pkgconfig.patch \
17 "
18
19SRC_URI[md5sum] = "5217ef3e76a7275a2a3b569a12ddc989"
20SRC_URI[sha256sum] = "4f93aac6fecb7da2b92871bb9ee33032be6a87b174f54abf8ddf0911a22d29d2"
21
22BINCONFIG = "${bindir}/gpg-error-config"
23
Brad Bishop316dfdd2018-06-25 12:45:53 -040024inherit autotools binconfig-disabled pkgconfig gettext multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025CPPFLAGS += "-P"
26do_compile_prepend() {
27 TARGET_FILE=linux-gnu
28 if [ ${TARGET_OS} = "mingw32" ]; then
29 # There are no arch specific syscfg files for mingw32
30 TARGET_FILE=
31 elif [ ${TARGET_OS} != "linux" ]; then
32 TARGET_FILE=${TARGET_OS}
33 fi
34
35 case ${TARGET_ARCH} in
36 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
37 arm) TUPLE=arm-unknown-linux-gnueabi ;;
38 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
39 i586|i686) TUPLE=i686-pc-linux-gnu ;;
40 mips64*) TUPLE=mips64el-unknown-linux-gnuabi64 ;;
41 mips*el) TUPLE=mipsel-unknown-linux-gnu ;;
42 mips*) TUPLE=mips-unknown-linux-gnu ;;
43 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
44 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
45 esac
46
47 if [ -n "$TARGET_FILE" ]; then
48 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
49 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
50 fi
51}
52
53do_install_append() {
54 # we don't have common lisp in OE
55 rm -rf "${D}${datadir}/common-lisp/"
Brad Bishop316dfdd2018-06-25 12:45:53 -040056 oe_multilib_header gpg-error.h gpgrt.h
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057}
58
59FILES_${PN}-dev += "${bindir}/gpg-error"
60FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
61
62BBCLASSEXTEND = "native nativesdk"