blob: e2e7ff4aa86cc0d781443ec644a1b89824b6529a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
13
14SRC_URI[md5sum] = "4cf8937d161d3dd71a65f1684e317824"
15SRC_URI[sha256sum] = "1b0dc762f23abe4e0d29b77370e539fd35f31d8e8e0318d6ddccff395be68a22"
16
17S = "${WORKDIR}/libsoup-${PV}"
18
19inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
20
21# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
24PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
25
26EXTRA_OECONF = "--disable-vala"
27
28# When built without gnome support, libsoup-2.4 will contain only one shared lib
29# and will therefore become subject to renaming by debian.bbclass. Prevent
30# renaming in order to keep the package name consistent regardless of whether
31# gnome support is enabled or disabled.
32DEBIAN_NOAUTONAME_${PN} = "1"
33
34# glib-networking is needed for SSL, proxies, etc.
35RRECOMMENDS_${PN} = "glib-networking"