blob: 1fefd1475680becd8dd4b6ba9de96f7a34d4243f [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Userspace library to access USB (version 1.0)"
2HOMEPAGE = "http://libusb.sf.net"
3BUGTRACKER = "http://www.libusb.org/report"
4SECTION = "libs"
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
8
9BBCLASSEXTEND = "native nativesdk"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
12 file://no-dll.patch \
13 "
14
15SRC_URI[md5sum] = "1da9ea3c27b3858fa85c5f4466003e44"
16SRC_URI[sha256sum] = "7dce9cce9a81194b7065ee912bcd55eeffebab694ea403ffb91b67db66b1824b"
17
18S = "${WORKDIR}/libusb-${PV}"
19
20inherit autotools pkgconfig
21
22# Don't configure udev by default since it will cause a circular
23# dependecy with udev package, which depends on libusb
24EXTRA_OECONF = "--libdir=${base_libdir} --disable-udev"
25
26do_install_append() {
27 install -d ${D}${libdir}
28 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
29 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
30 fi
31}
32
33FILES_${PN} += "${base_libdir}/*.so.*"
34
35FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"