blob: 26171623525d780efa8470910c2a123d5fdb7fb9 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "An extension to cryptsetup/LUKS that enables use of the TPM 2.0 via tpm2-tss"
2DESCRIPTION = "Cryptsetup is utility used to conveniently setup disk encryption based on DMCrypt kernel module."
3
4SECTION = "security/tpm"
5LICENSE = "LGPL-2.1 | GPL-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326 \
7 file://COPYING.LGPL;md5=1960515788100ce5f9c98ea78a65dc52 \
8 "
9
10DEPENDS = "autoconf-archive pkgconfig gettext libtss2-dev libdevmapper popt libgcrypt json-c"
11
12SRC_URI = "git://github.com/AndreasFuchsSIT/cryptsetup-tpm-incubator.git;branch=luks2tpm \
13 file://configure_fix.patch "
14
15SRCREV = "15c283195f19f1d980e39ba45448683d5e383179"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig gettext
20
21PACKAGECONFIG ??= "openssl"
22PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl"
23PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt"
24
25EXTRA_OECONF = "--enable-static"
26
27RRECOMMENDS_${PN} = "kernel-module-aes-generic \
28 kernel-module-dm-crypt \
29 kernel-module-md5 \
30 kernel-module-cbc \
31 kernel-module-sha256-generic \
32 kernel-module-xts \
33 "
34
Brad Bishop95dbbac2019-12-02 13:55:25 -050035FILES_${PN} += "${libdir}/tmpfiles.d"
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040036RDEPENDS_${PN} += "lvm2 libdevmapper"
Brad Bishop19323692019-04-05 15:28:33 -040037RRECOMMENDS_${PN} += "lvm2-udevrules"
38
Andrew Geissler5bea8d82020-07-24 16:10:05 -050039RPROVIDES_${PN} = "cryptsetup"
Brad Bishop19323692019-04-05 15:28:33 -040040RREPLACES_${PN} = "cryptsetup"
41RCONFLICTS_${PN} ="cryptsetup"
42
Andrew Geissler5bea8d82020-07-24 16:10:05 -050043RPROVIDES_${PN}-dev = "cryptsetup-dev"
44RREPLACES_${PN}-dev = "cryptsetup-dev"
45RCONFLICTS_${PN}-dev ="cryptsetup-dev"
46
Brad Bishop19323692019-04-05 15:28:33 -040047BBCLASSEXTEND = "native nativesdk"