blob: be23646e717f172717689dbc84aa22f846409cbd [file] [log] [blame]
Jason M. Billsc8659172018-10-26 14:07:48 -07001SUMMARY = "Journal IPMI SEL Logger"
2DESCRIPTION = "Utility to write IPMI SEL records to the journal"
3
4# SEL Logger has the ability to monitor and automatically log SEL records for
5# various types of events, but this is disabled by default. The following
6# flags can be set in a .bbappend to enable specific types of event
7# monitoring:
8#
9# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
10# Monitors and logs SEL records for threshold sensor events
11
12inherit cmake systemd
13S = "${WORKDIR}/git/"
14
15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
17
18DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host"
19
20SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
Andrew Geissler5dd50632020-07-22 21:51:32 +000021SRCREV = "25b26e162bd109b51aa09b16f26f9aa3d9d940fa"
Jason M. Billsc8659172018-10-26 14:07:48 -070022
23PV = "0.1+git${SRCPV}"
24
25SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"