blob: b6bc5241c756bed9a849d50ab8272befb40694b6 [file] [log] [blame]
Vijay Khemka4809bd12019-12-16 17:48:02 -08001SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
Ed Tanous9936f862022-09-19 09:13:20 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Andrew Geissler5df2a052023-04-23 20:20:50 -05007SRCREV = "a4c19b0032900982b4e8ae85791f4dbd498457a8"
Ed Tanous9936f862022-09-19 09:13:20 -07008PV = "1.0+git${SRCPV}"
Vijay Khemka4809bd12019-12-16 17:48:02 -08009
Patrick Williamsbb99d222022-01-24 15:55:09 -060010SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git;branch=master;protocol=https"
Vijay Khemka4809bd12019-12-16 17:48:02 -080011
12S = "${WORKDIR}/git"
13
Manojkiran Edaad8a30c2021-12-12 15:44:38 +053014inherit meson pkgconfig systemd
Vijay Khemka4809bd12019-12-16 17:48:02 -080015
Kumar Thangavel27cb8232020-09-01 23:05:19 +053016def get_service(d):
Kumar Thangavel21367312022-12-07 20:15:58 +053017 return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
18
Patrick Williams12fc9392021-08-06 09:16:53 -050019SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
Vijay Khemka4809bd12019-12-16 17:48:02 -080020DEPENDS += " \
21 sdbusplus \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
Manojkiran Edaad8a30c2021-12-12 15:44:38 +053024 libcereal \
Vijay Khemka4809bd12019-12-16 17:48:02 -080025 "
Kumar Thangavel21367312022-12-07 20:15:58 +053026FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
27FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"