blob: 0f105c239375d23518e85973186e2742a3ed608c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The PyPA recommended tool for installing Python packages"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05002HOMEPAGE = "https://pypi.org/project/pip"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SECTION = "devel/python"
4LICENSE = "MIT"
Andrew Geissler5f350902021-07-23 13:09:54 -04005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c4fa2b50f55649f43060fa04b0919b9b"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7DEPENDS += "python3 python3-setuptools-native"
8
Andrew Geissler5f350902021-07-23 13:09:54 -04009inherit pypi distutils3
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011SRC_URI += "file://0001-change-shebang-to-python3.patch"
12
Andrew Geissler5f350902021-07-23 13:09:54 -040013SRC_URI[sha256sum] = "b5b1eb91b36894bd01b8e5a56a422c2f3838573da0b0a1c63a096bb454e3b23f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15do_install_append() {
16 # Install as pip3 and leave pip2 as default
17 rm ${D}/${bindir}/pip
18}
19
20RDEPENDS_${PN} = "\
21 python3-compile \
22 python3-io \
23 python3-html \
24 python3-json \
Andrew Geissler5f350902021-07-23 13:09:54 -040025 python3-multiprocessing \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 python3-netserver \
27 python3-setuptools \
28 python3-unixadmin \
29 python3-xmlrpc \
30 python3-pickle \
31"
32
33BBCLASSEXTEND = "native nativesdk"