blob: e5046ffbe1d3c11b53b72a2ccf557ad799107d8a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Documentation system for on-line information and printed output"
2DESCRIPTION = "Texinfo is a documentation system that can produce both \
3online information and printed output from a single source file. The \
4GNU Project uses the Texinfo file format for most of its documentation."
5HOMEPAGE = "http://www.gnu.org/software/texinfo/"
6SECTION = "console/utils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9
10PROVIDES_append_class-native = " texinfo-replacement-native"
11
12def compress_pkg(d):
13 if bb.data.inherits_class('compress_doc', d):
14 compress = d.getVar("DOC_COMPRESS")
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS_info += "${@compress_pkg(d)}"
24
25DEPENDS = "zlib ncurses texinfo-replacement-native"
26DEPENDS_class-native = "zlib-native ncurses-native"
27
28TARGET_PATCH = "file://use_host_makedoc.patch"
29TARGET_PATCH_class-native = ""
30
31SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 file://disable-native-tools.patch \
33 file://link-zip.patch \
34 file://dont-depend-on-help2man.patch \
35 ${TARGET_PATCH} \
36 "
37
Andrew Geissler5f350902021-07-23 13:09:54 -040038SRC_URI[sha256sum] = "8e09cf753ad1833695d2bac0f57dc3bd6bcbbfbf279450e1ba3bc2d7fb297d08"
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
40tex_texinfo = "texmf/tex/texinfo"
41
42inherit gettext autotools multilib_script
43
44MULTILIB_SCRIPTS = "${PN}:${bindir}/texi2any"
45
46EXTRA_AUTORECONF += "-I ${S}/gnulib/m4"
47
48do_configure_prepend () {
49 # autotools_do_configure updates po/Makefile.in.in, we also need
50 # update po_document.
51 cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/
52}
53
54do_compile_prepend() {
55 if [ -d tools ];then
56 oe_runmake -C tools/gnulib/lib
57 fi
58}
59
60do_install_append() {
61 mkdir -p ${D}${datadir}/${tex_texinfo}
62 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
63 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi
64}
65
66do_install_append_class-native() {
67 install -m 755 info/makedoc ${D}${bindir}
68}
69
70PACKAGES += "info info-doc"
71
72FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
73FILES_info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \
74 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
75 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
76
77FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
78RDEPENDS_${PN} = "perl"
79FILES_${PN}-doc = "${infodir}/texinfo* \
80 ${datadir}/${tex_texinfo} \
81 ${mandir}/man1 ${mandir}/man5"
82
83# Lie about providing the Locale::gettext_xs module. It is not actually built,
84# but the code will test for it and if not found use Locale::gettext_pp instead.
85# However, this causes a file dependency on perl(Locale::gettext_xs) to be
86# generated, which must be satisfied.
87RPROVIDES_${PN} += "perl(Locale::gettext_xs)"
88
89BBCLASSEXTEND = "native nativesdk"