blob: 5f61c4ecddc7a6d49df2ab73bc92ddc9775020bc [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit python3-dir
10
11EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
12
13do_compile() {
14 oe_runmake hwlatdetect
15}
16
17do_install() {
18 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
19 MANDIR=${mandir} INCLUDEDIR=${includedir}
20
21 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025RDEPENDS_${PN} = "python3-core "
Patrick Williamsc0f7c042017-02-23 20:41:17 -060026RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"