blob: 96b6cab49c1d12cb4e9fa631c1ae87a9927753e8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018 file://include_xutil.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050019 file://reduce-memory-overheads.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050020 file://musl-lower-stack-usage.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050021 file://0001-MiniBrowser-Fix-reproduciblity.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022 file://0001-Properly-use-CompletionHandler-when-USE_OPENGL_OR_ES.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050024
Andrew Geissler5f350902021-07-23 13:09:54 -040025SRC_URI[sha256sum] = "1790f86975bdef957ba9a12fc09202de8f55c885ee38467afc50d2bdb7a6c5cd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
28
29ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
30REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
31
32CVE_PRODUCT = "webkitgtk webkitgtk\+"
33
34DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
35 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
36 pango icu bison-native gawk intltool-native libwebp \
37 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
38 ruby-native libnotify gstreamer1.0-plugins-bad \
39 gettext-native glib-2.0 glib-2.0-native libtasn1 \
40 "
41
Andrew Geissler6ce62a22020-11-30 19:58:47 -060042PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050043 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 enchant \
46 libsecret \
47 "
48
49PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
50PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
51PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
52PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
53PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
54PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060055PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
57PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
58PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
59PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060060PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -050061PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050062
63# webkitgtk is full of /usr/bin/env python, particular for generating docs
64do_configure[postfuncs] += "setup_python_link"
65setup_python_link() {
66 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
67 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
68 fi
69}
70
71EXTRA_OECMAKE = " \
72 -DPORT=GTK \
Andrew Geissler82c905d2020-04-13 13:39:40 -050073 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
74 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
75 -DENABLE_MINIBROWSER=ON \
76 -DPYTHON_EXECUTABLE=`which python3` \
77 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070078 -DENABLE_GAMEPAD=OFF \
Andrew Geissler82c905d2020-04-13 13:39:40 -050079 "
80
81# Javascript JIT is not supported on ARC
82EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
83# By default 25-bit "medium" calls are used on ARC
84# which is not enough for binaries larger than 32 MiB
85CFLAGS_append_arc = " -mlong-calls"
86CXXFLAGS_append_arc = " -mlong-calls"
87
88# Javascript JIT is not supported on powerpc
89EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
90EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
91
92# ARM JIT code does not build on ARMv4/5/6 anymore
93EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
94EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
95EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
96
97EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
98EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
99
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600100# JIT and gold linker does not work on RISCV
101EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
102EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
103
Andrew Geissler82c905d2020-04-13 13:39:40 -0500104# JIT not supported on MIPS either
105EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
106
107# JIT not supported on X32
108# An attempt was made to upstream JIT support for x32 in
109# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
110# unresolved due to limited X32 adoption.
111EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
112
113SECURITY_CFLAGS_remove_aarch64 = "-fpie"
114SECURITY_CFLAGS_append_aarch64 = " -fPIE"
115
116FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
117
118RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
119
120# http://errors.yoctoproject.org/Errors/Details/20370/
121ARM_INSTRUCTION_SET_armv4 = "arm"
122ARM_INSTRUCTION_SET_armv5 = "arm"
123ARM_INSTRUCTION_SET_armv6 = "arm"
124
125# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
126# https://bugs.webkit.org/show_bug.cgi?id=159880
127# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
128# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
129ARM_INSTRUCTION_SET_armv7a = "thumb"
130ARM_INSTRUCTION_SET_armv7r = "thumb"
131ARM_INSTRUCTION_SET_armv7ve = "thumb"
132
133# introspection inside qemu-arm hangs forever on musl/arm builds
134# therefore disable GI_DATA
135GI_DATA_ENABLED_libc-musl_armv7a = "False"
136GI_DATA_ENABLED_libc-musl_armv7ve = "False"
137
138# Can't be built with ccache
139CCACHE_DISABLE = "1"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600140
141PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
142src_package_preprocess () {
143 # Trim build paths from comments in generated sources to ensure reproducibility
144 sed -i -e "s,${WORKDIR},,g" \
145 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
146 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
147 ${B}/DerivedSources/JavaScriptCore/*.h \
148 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
149 ${B}/DerivedSources/MiniBrowser/*.c
150}
151