Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A patent-free DSP library" |
| 2 | DESCRIPTION = "SpeexDSP is a patent-free, Open Source/Free Software DSP library." |
| 3 | HOMEPAGE = "http://www.speex.org" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=314649d8ba9dd7045dfb6683f298d0a8" |
| 7 | |
| 8 | SRC_URI = "http://downloads.xiph.org/releases/speex/speexdsp-${PV}.tar.gz \ |
| 9 | file://0001-Don-t-rely-on-HAVE_STDINT_H-et-al.-being-defined.patch" |
| 10 | |
| 11 | SRC_URI[md5sum] = "70d9d31184f7eb761192fd1ef0b73333" |
| 12 | SRC_URI[sha256sum] = "4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1" |
| 13 | |
| 14 | inherit autotools pkgconfig |
| 15 | |
| 16 | EXTRA_OECONF = "\ |
| 17 | --disable-examples \ |
| 18 | ${@bb.utils.contains('TARGET_FPU', 'soft', '--enable-fixed-point --disable-float-api', '', d)} \ |
| 19 | " |
| 20 | |
| 21 | # Workaround for a build failure when building with MACHINE=qemuarm64. I think |
| 22 | # aarch64 is supposed to support NEON just fine, but building for qemuarm64 |
| 23 | # fails in NEON code: |
| 24 | # |
| 25 | # .../speexdsp-1.2rc3/libspeexdsp/resample_neon.h:148:5: error: impossible constraint in 'asm' |
| 26 | # asm volatile (" cmp %[len], #0\n" |
| 27 | # ^ |
| 28 | # |
| 29 | # I sent an email about the issue to speex-dev. At the time of writing there |
| 30 | # are no responses yet: |
| 31 | # http://thread.gmane.org/gmane.comp.audio.compression.speex.devel/7360 |
| 32 | EXTRA_OECONF += "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--disable-neon', '', d)}" |
| 33 | |
| 34 | # speexdsp was split off from speex in 1.2rc2. Older versions of speex can't |
| 35 | # be installed together with speexdsp, since they contain overlapping files. |
| 36 | RCONFLICTS_${PN} = "speex (< 1.2rc2)" |
| 37 | RCONFLICTS_${PN}-dbg = "speex-dbg (< 1.2rc2)" |
| 38 | RCONFLICTS_${PN}-dev = "speex-dev (< 1.2rc2)" |
| 39 | RCONFLICTS_${PN}-staticdev = "speex-staticdev (< 1.2rc2)" |