blob: 7e31b32e81a7b0ea45088d5f43f8844e14d63fe8 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw python3native
2
3ESW_COMPONENT_SRC = "/ThirdParty/sw_services/lwip211/src/"
4ESW_COMPONENT_NAME = "liblwip211.a"
5
6DEPENDS += "dtc-native python3-dtc-native libxil python3-pyyaml-native"
7DEPENDS_append_xilinx-freertos = "freertos10-xilinx"
8
9do_configure_prepend() {
10 # This script should also not rely on relative paths and such
11 cd ${S}
12 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH}
13}
14
15do_install() {
16 install -d ${D}${libdir}
17 install -d ${D}${includedir}
18 install -m 0755 ${B}/${ESW_COMPONENT_NAME} ${D}${libdir}
19 install -m 0644 ${B}/include/*.h ${D}${includedir}
20 cp -r ${B}/include/arch/ ${D}${includedir}
21 cp -r ${B}/include/include/lwip/ ${D}${includedir}
22 cp -r ${B}/include/include/netif/ ${D}${includedir}
23}