blob: 705cad8d914a9ab7557bb57052e1df5af631652c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Common code for generating core reference images
2#
3# Copyright (C) 2007-2011 Linux Foundation
4
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8# IMAGE_FEATURES control content of the core reference images
9#
10# By default we install packagegroup-core-boot and packagegroup-base-extended packages;
11# this gives us working (console only) rootfs.
12#
13# Available IMAGE_FEATURES:
14#
15# - x11 - X server
16# - x11-base - X server with minimal environment
17# - x11-sato - OpenedHand Sato environment
18# - tools-debug - debugging tools
19# - eclipse-debug - Eclipse remote debugging support
20# - tools-profile - profiling tools
21# - tools-testapps - tools usable to make some device tests
22# - tools-sdk - SDK (C/C++ compiler, autotools, etc.)
23# - nfs-server - NFS server
24# - nfs-client - NFS client
25# - ssh-server-dropbear - SSH server (dropbear)
26# - ssh-server-openssh - SSH server (openssh)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027# - hwcodecs - Install hardware acceleration codecs
28# - package-management - installs package management tools and preserves the package manager database
29# - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins
30# - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs
31# - dbg-pkgs - debug symbol packages for all installed packages in the rootfs
32# - doc-pkgs - documentation packages for all installed packages in the rootfs
33# - ptest-pkgs - ptest packages for all ptest-enabled recipes
34# - read-only-rootfs - tweaks an image to support read-only rootfs
35#
36FEATURE_PACKAGES_x11 = "packagegroup-core-x11"
37FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base"
38FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato"
39FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug"
40FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug"
41FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile"
42FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps"
43FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target"
44FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server"
45FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client"
46FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear"
47FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}"
49
50
51# IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2'
52# Including image feature foo would replace the image features bar1 and bar2
53IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
54
55# IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
56# An error exception would be raised if both image features foo and bar1(or bar2) are included
57
58MACHINE_HWCODECS ??= ""
59
60CORE_IMAGE_BASE_INSTALL = '\
61 packagegroup-core-boot \
62 packagegroup-base-extended \
63 \
64 ${CORE_IMAGE_EXTRA_INSTALL} \
65 '
66
67CORE_IMAGE_EXTRA_INSTALL ?= ""
68
69IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
70
71inherit image