blob: a558871e99facf6c94850f84e33aa61aa50906b0 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# This class installs additional files found on the build host
2# directly into the rootfs.
3#
4# One use case is to install a constant ssh host key in
5# an image that gets created for just one machine. This
6# solves two issues:
7# - host key generation on the device can stall when the
8# kernel has not gathered enough entropy yet (seen in practice
9# under qemu)
10# - ssh complains by default when the host key changes
11#
12# For dropbear, with the ssh host key store along side the local.conf:
13# 1. Extend local.conf:
14# INHERIT += "rootfsdebugfiles"
15# ROOTFS_DEBUG_FILES += "${TOPDIR}/conf/dropbear_rsa_host_key ${IMAGE_ROOTFS}/etc/dropbear/dropbear_rsa_host_key ;"
16# 2. Boot the image once, copy the dropbear_rsa_host_key from
17# the device into your build conf directory.
18#
19# Do not use for production images! It bypasses several
20# core build mechanisms (updating the image when one
21# of the files changes, license tracking in the image
22# manifest, ...).
23
24ROOTFS_DEBUG_FILES ?= ""
25ROOTFS_DEBUG_FILES[doc] = "Lists additional files or directories to be installed with 'cp -a' in the format 'source1 target1;source2 target2;...'"
26
27ROOTFS_POSTPROCESS_COMMAND += "rootfs_debug_files ;"
28rootfs_debug_files () {
29 #!/bin/sh -e
30 echo "${ROOTFS_DEBUG_FILES}" | sed -e 's/;/\n/g' | while read source target; do
31 if [ -e "$source" ]; then
32 mkdir -p $(dirname $target)
33 cp -a $source $target
34 fi
35 done
36}