blob: 376ab542dd5c21caa0523ece6c66672691a10d46 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools pkgconfig
10inherit deploy
11
12PV = "48+git${SRCPV}"
13SRCREV = "2bcd919c681c952eb867ef1bdb458f1bc49c2d55"
14SRC_URI = "git://anongit.freedesktop.org/gummiboot \
15 file://fix-objcopy.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050016 file://0001-console-Fix-C-syntax-errors-for-function-declaration.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017 "
18
19# Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi
20# which has set the COMPATIBLE_HOST, the gummiboot itself may work on
21# more hosts.
22COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
23
24S = "${WORKDIR}/git"
25
26EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
27 --with-efi-ldsdir=${STAGING_LIBDIR} \
28 --with-efi-libdir=${STAGING_LIBDIR}"
29
30EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
31
Patrick Williamsf1e5d692016-03-30 15:21:19 -050032TUNE_CCARGS_remove = "-mfpmath=sse"
33
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034do_deploy () {
35 install ${B}/gummiboot*.efi ${DEPLOYDIR}
36}
37addtask deploy before do_build after do_compile