blob: 93bddb34ce9a202fed5aa789f1a1ac767d0ac672 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux NFC daemon"
2DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
3HOMEPAGE = "http://01.org/linux-nfc"
4LICENSE = "GPLv2"
5
6DEPENDS = "dbus glib-2.0 libnl"
7
8SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BP}.tar.xz \
9 file://neard.in \
10 file://Makefile.am-fix-parallel-issue.patch \
11 file://Makefile.am-do-not-ship-version.h.patch \
12 "
13SRC_URI[md5sum] = "b746ce62eeef88e8de90765e00a75a1c"
14SRC_URI[sha256sum] = "651f6513d32cdaf8a426255d03aff38a6620a89b0567ec2b36606c6330a93353"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
17 file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
18 "
19
20inherit autotools pkgconfig systemd update-rc.d bluetooth
21
22PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
23
24PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd"
25
26EXTRA_OECONF += "--enable-tools"
27
28# This would copy neard start-stop shell and test scripts
29do_install_append() {
30 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
31 install -d ${D}${sysconfdir}/init.d/
32 sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \
33 > ${D}${sysconfdir}/init.d/neard
34 chmod 0755 ${D}${sysconfdir}/init.d/neard
35 fi
36
37 # Install the tests for neard-tests
38 install -d ${D}${libdir}/neard
39 install -m 0755 ${S}/test/* ${D}${libdir}/${BPN}/
40 install -m 0755 ${B}/tools/nfctool/nfctool ${D}${libdir}/${BPN}/
41}
42
43PACKAGES =+ "${PN}-tests"
44
45FILES_${PN}-tests = "${libdir}/${BPN}/*-test"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046
47RDEPENDS_${PN} = "dbus python python-dbus python-pygobject"
48
49# Bluez & Wifi are not mandatory except for handover
50RRECOMMENDS_${PN} = "\
51 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
53 "
54
55RDEPENDS_${PN}-tests = "python python-dbus python-pygobject"
56
57INITSCRIPT_NAME = "neard"
58INITSCRIPT_PARAMS = "defaults 64"
59
60SYSTEMD_SERVICE_${PN} = "neard.service"