blob: 88b3b30197f869602dcf65447eb659588ec2bf82 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Live image install script for grub"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install.sh"
5
6PR = "r9"
7
8S = "${WORKDIR}"
9
10RDEPENDS_${PN} = "grub parted e2fsprogs-mke2fs util-linux-blkid"
11
12do_install() {
13 install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
14}
15
16# While this package maybe an allarch due to it being a
17# simple script, reality is that it is Host specific based
18# on the COMPATIBLE_HOST below, which needs to take precedence
19#inherit allarch
20INHIBIT_DEFAULT_DEPS = "1"
21
22FILES_${PN} = " /install.sh "
23
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"