blob: 86c57cda20d71ac9ec9f2607b19714f042610101 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Integrated Development Environment support"
2DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native"
8PR = "r3"
9
10inherit meta toolchain-scripts
11
12do_populate_ide_support () {
13 toolchain_create_tree_env_script
14}
15
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016addtask populate_ide_support before do_build after do_install