blob: 0b8ff09b2b3c5e091336a02cdddd58cfc6202d74 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Enhances systemd compatilibity with existing SysVinit scripts"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6PR = "r29"
7
8DEPENDS = "systemd-systemctl-native"
9
10S = "${WORKDIR}"
11
12inherit allarch
13
14ALLOW_EMPTY_${PN} = "1"
15
16SYSTEMD_DISABLED_SYSV_SERVICES = " \
17 busybox-udhcpc \
18 hwclock \
19 networking \
20 nfsserver \
21 nfscommon \
22 syslog.busybox \
23"
24
25pkg_postinst_${PN} () {
26 cd $D${sysconfdir}/init.d
27
28 echo "Disabling the following sysv scripts: "
29
30 OPTS=""
31
32 if [ -n "$D" ]; then
33 OPTS="--root=$D"
34 fi
35
36 for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
37 if [ \( -e $i -o $i.sh \) -a ! \( -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service \) ] ; then
38 echo -n "$i: " ; systemctl ${OPTS} mask $i.service
39 fi
40 done ; echo
41}
42
43RDPEPENDS_${PN} = "systemd"