blob: c15cb78033779b3f1bbeeb21d66543ae63e65806 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "manage symlinks in /etc/rcN.d"
2DESCRIPTION = "update-rc.d is a utilities that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
3SECTION = "base"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
7
8PR = "r5"
9
10# Revision corresponding to tag update-rc.d_0.7
11SRCREV = "eca680ddf28d024954895f59a241a622dd575c11"
12
13SRC_URI = "git://github.com/philb/update-rc.d.git \
14 file://add-verbose.patch \
15 file://check-if-symlinks-are-valid.patch \
16 file://fix-to-handle-priority-numbers-correctly.patch \
17 "
18
19S = "${WORKDIR}/git"
20
21inherit allarch
22
23do_compile() {
24}
25
26do_install() {
27 install -d ${D}${sbindir}
28 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
29}
30
31BBCLASSEXTEND = "native"