blob: 182e8802b2136f7a74acd0c2d80384a3bea18a4c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12PR = "r1"
13
14SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
15 file://bison-2.3_m4.patch"
16
17SRC_URI[md5sum] = "22327efdd5080e2b1acb6e560a04b43a"
18SRC_URI[sha256sum] = "52f78aa4761a74ceb7fdf770f3554dd84308c3b93c4255e3a5c17558ecda293e"
19
20inherit autotools gettext texinfo
21acpaths = "-I ${S}/m4"
22
23do_configure_prepend () {
24 rm -f ${S}/m4/*gl.m4
25 cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/
26}