blob: 48a2f935befe90c54e42c79e3881dd085a3de446 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native pkgconfig-native"
15RDEPENDS_${PN} += "python bash"
16SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BP}.tar.xz"
17
18SRC_URI[md5sum] = "b939280dcc83f8feabd87a1d5f9b00c2"
19SRC_URI[sha256sum] = "ea2615a62c74bea6ce3b38402f00c7513858f307f6ba7aa9fdbf0bbc12bcf407"
20
21inherit autotools
22do_configure_prepend () {
23 mkdir -p scripts/.autostuff/m4
24}
25
26do_install_append() {
27 ln -s kconfig-conf ${D}${bindir}/conf
28 ln -s kconfig-mconf ${D}${bindir}/mconf
29}
30
31EXTRA_OECONF += "--disable-gconf --disable-qconf"
32
33# Some packages have the version preceeding the .so instead properly
34# versioned .so.<version>, so we need to reorder and repackage.
35SOLIBS = "-${@d.getVar('PV',1)[:-2]}.so"
36FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
37
38BBCLASSEXTEND = "native"