blob: e0724e68add55c0e193bc89036d4aef07f5fbfff [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7
8SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
9
10SRC_URI[md5sum] = "7aae5cb8e03fac48029c82a7470ab066"
11SRC_URI[sha256sum] = "9da3a0291a0bdc06305b7ba194f1e2c2b55ae6f11210b4af43729868149d5445"
12
13inherit autotools-brokensep
14
15do_configure_prepend () {
16 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
17 mv ${S}/aclocal.m4 ${S}/acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24
25 oe_runmake 'INSTALLROOT=${D}' install
26}
27
28BBCLASSEXTEND = "native"
29
30DEPENDS = "groff-native"